Back to overview
Downtime

Yuma Internet Outage

Jul 12, 2023 at 3:13am UTC
Affected services
Yuma
Yuma
Yuma

Resolved
Jul 12, 2023 at 2:15pm UTC

Services have been restored, we are monitoring internet connections.

Updated
Jul 12, 2023 at 5:41am UTC

VistaBeam has identified the failed hardware. Estimated time of repairs 7:00am MT.

Created
Jul 12, 2023 at 3:13am UTC

The ISP is currently investigating an outage. External access to Yuma is impacted and Corporate reports may be delayed.